Project

General

Profile

Actions

Task / Tâche #3896

closed

Login form needs meta-data to mark it as login form

Added by Ced about 9 years ago. Updated almost 9 years ago.

Status:
Closed
Priority:
Low
Assignee:
Category:
-
Target version:
-
Start date:
24 October 2012
Due date:
12 March 2013
% Done:

100%

Estimated time:
1.00 h

Description

Observation

  • I cannot store the username and password via my browser's "save form credentials" feature.

Expectation

  • The form is properly marked as a login form to enable this feature. It is unnerving to open my password management tool every-time I need to login. Demotivates me to do any work for the party.

Related issues

Related to Digitale Infrastruktur - Motion #4478: CAS SettingsConsideredApophis28 January 201327 February 2013

Actions
Actions #1

Updated by Apophis about 9 years ago

  • Status changed from New to 4
  • Assignee set to Ced
  • Priority changed from Normal to Low
  • Estimated time set to 1.00 h

Please specify which form on what page, assigne the ticket back to me.

Actions #2

Updated by admin about 9 years ago

  • Due date set to 12 March 2013

Automatically enforce due date for Low Priority after 60 days in the future

Actions #3

Updated by Apophis almost 9 years ago

  • Status changed from Needs Feedback to Won't Do

No reaction within a month. -> Won't do.

Actions #4

Updated by Ced almost 9 years ago

  • Status changed from Won't Do to Needs Work
  • Assignee changed from Ced to Apophis

Excuse me, completely forgot about this issue. I meant the central login form (going to projects.piratenpartei.ch without being logged in).

Actions #5

Updated by Apophis almost 9 years ago

  • Assignee changed from Apophis to corvus

This is our central CAS-Server. Since it is a Single Sign On Solution, I am pretty sure this is by design.

corvus, what do you think?

Actions #6

Updated by corvus almost 9 years ago

  • Status changed from Needs Work to Needs Feedback
  • Assignee changed from corvus to Apophis

Yes, this is by design for the password field explicitly denies autocompletion.

I am not sure if we should leave it that way or what the security penalty would be if we change that.

Actions #7

Updated by admin almost 9 years ago

  • Assignee changed from Apophis to Ced

Automaticaclly enforce assigned-to to the author of the ticket

Actions #8

Updated by Apophis almost 9 years ago

  • Status changed from Needs Feedback to Won't Do

OK Ced, this functionality is by design.

I'll close this Issue as Won't do, but we will discuss it on the next meeting, please refer to motion #4478

Actions #9

Updated by Apophis almost 9 years ago

OK entscheidung der AG DI Sitzung:

  • Wir werden das nicht anpassen, Simon Rupf schlägt dir den "LastPass" Passwort manager vor, der kann das.
  • Wir werden CAS so konfigurieren dass man 30 Tage eingeloggt bleibt und so das Passwort nicht mehr so oft eingeben muss.
Actions #10

Updated by admin almost 9 years ago

  • Status changed from Won't Do to Closed

Automatically close after 30 days

Actions

Also available in: Atom PDF