Project

General

Profile

Bug / Feature #7802

SSL-Zertifikat des Mumble abgelaufen

Added by janfader over 2 years ago. Updated 4 months ago.

Status:
Closed
Priority:
High
Assignee:
Category:
Infra
Target version:
-
Start date:
13 February 2018
Due date:
% Done:

0%

Estimated time:
2.00 h
Request Type:
Bug Report

Description

Das SSL-Zertifikat des Mumble-Servers ist abgelaufen. Bitte, falls möglich, auf LetsEncrypt umstellen. Andernfalls bitte einfach verlängern.

History

#1

Updated by Atropos over 2 years ago

Ich wäre sehr froh, wenn das vor dem 13.3. gefixt ist. Weil dann haben wir Kandidatenbefragung. Und so könnten einige Supportfälle vermieden werden.

#2

Updated by philhug over 2 years ago

damit das mit letsencrypt klappt müssen wir wohl DNS challenges verwenden.
dazu bräuchten wir den container um die zertis abzuholen:
https://github.com/adferrand/docker-letsencrypt-dns

und die zugangsdaten zu luadns im vault
LEXICON_PROVIDER=luadns
LEXICON_LUADNS_USERNAME=my_user
LEXICON_LUADNS_TOKEN=my_secret_token

#3

Updated by jowi over 2 years ago

http://talk.piratenpartei.ch/ spricht doch sowieso schon HTTP, dann können wir auch ACME http-01 verwenden.
Das Zertifikat können sich HTTP und Mumble problemlos teilen.

#4

Updated by philhug over 2 years ago

jowi wrote:

http://talk.piratenpartei.ch/ spricht doch sowieso schon HTTP, dann können wir auch ACME http-01 verwenden.
Das Zertifikat können sich HTTP und Mumble problemlos teilen.

Problematik ist, dass dieses Zertifikat nur auf dem Traefik verfuegbar und nur innerhalb des acme.json

#5

Updated by janfader about 2 years ago

  • Estimated time set to 2.00 h
#7

Updated by jowi 5 months ago

  • Status changed from New to Done
  • Assignee changed from philhug to jowi
#8

Updated by jowi 4 months ago

  • Status changed from Done to Closed

Also available in: Atom PDF